Installer for 2.5.32 ignores selected installation path


Author
Message
stefando
stefando
New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)
Group: Forum Members
Posts: 3, Visits: 4
Hi, 

  Installer for version 2.5.32 ignores the selected installation location and installs the program into the program files folder.
  Even click on the big green run icon fails.

~S
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Hi Stefando,

I suspect what has happened here is that you specified a non-default installation path and then requested a 'Per User' installation.  'Per User' installations will ignore the installation path as they always install to the same location - %LocalAppData%\Programs\LogViewPlus.  I will update the documentation to reflect this.

To set the install path, please install LogViewPlus for 'All Users'.  This action will require administrator permissions.

I can see that the flow of the install wizard is a bit confusing here as the path should not be shown at all if it will not be changed.  I will raise this issue with our third-party install provider.

Hope that helps,

Toby
stefando
stefando
New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)
Group: Forum Members
Posts: 3, Visits: 4
Hello Toby, 
I specified the custom install location, chose "all users" installation.
The program has been installed into the "Program Files" folder, not the one I specified.
~S
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Thanks for confirming.  I have just tested on my machine and successfully recreated the issue.

We have modified the installer in LogViewPlus v2.5.32 to support an admin-free installation with the 'per user' option.  We must have missed this issue in our testing.  For now, I would suggest reverting to the previous version v2.5.22.  I have just tested and can confirm that the 22 release respects the target installation directory.

I will take a closer look and post back here when the issue is resolved.

Thanks for bringing this problem to our attention.

Toby
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
If you install the previous release and then upgrade to the current release, the target installation path is still respected.  Obviously, this is not a long-term solution, but it might help until we can get the issue fixed and released.

Toby
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Hi Stefando,

I just wanted to let you know that we have now released LogViewPlus 2.5.34 as a BETA release.  We spent a lot of time on this release revisiting the installer to address this path problem as well as some other issues we were having regarding assembly registration and usability.  I think the new approach is a solid improvement.

Thanks again for bringing this problem to our attention.  Please do let me know if you have any further comments or suggestions.

Toby 
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search