Log files not updating


Author
Message
Brad Konia
Brad Konia
Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)
Group: Forum Members
Posts: 48, Visits: 73
Most of the time, LVP updates a log within a few seconds of the file being written to. However, I sometimes encounter situations where log files stop updating completely. For example, I just checked one of my log files in LVP and the last entry was from a week ago. I knew that was wrong, so I checked the monitoring pane and it showed that the file was being actively monitored. Then I closed and reopened the workspace. After that, it showed the hundreds of log entries from the past week.

I have LVP installed on my laptop and the machine is frequently suspended without an Internet connection when I'm moving about. Therefore, I'm wondering if it loses the connection while the machine is suspended, then fails to reestablish the connection when the Internet connection is restored. I think the monitoring function needs to be made more robust to account for this scenario.
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Thanks for reporting this issues Brad.

I will need to investigate this issue and get back to you.  In the meantime, if you detect a loss of connection, refreshing your log file (F5) may be the best work-around.

As suggested, the issue is probably related to the laptop suspension / loss of connection.  The fix here will likely involve improved error detection and reporting.  If we were to refresh the connection automatically, important log entries may be lost.  If we resume the connection, there will be  a gap where log entries may have been written.

Thanks again,

Toby
Brad Konia
Brad Konia
Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)
Group: Forum Members
Posts: 48, Visits: 73
Actually, in this case, I first tried refreshing the log file and that didn't work. Then I closed and re-opened the worksspace.
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
That's interesting.  I would have expected a full refresh to resolve the issue.

Thanks for the update.  I will take a closer look and get back to you.
Brad Konia
Brad Konia
Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)
Group: Forum Members
Posts: 48, Visits: 73
This just happened again, but this time I was able to refresh the file using the Reload File option from the context menu. 
Brad Konia
Brad Konia
Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)
Group: Forum Members
Posts: 48, Visits: 73
Juts wondering if you're making any progress on this issue. It pretty much happens constantly, especially with larger log files. At least for me, the tailing mechanism is mostly useless at this point. Any time I want to view the latest entries, I have to manually reload the file. 
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Hi Brad,

No update yet, but this is something we will be actively looking at over the next two weeks.  It is high on my list of priorities.  We will be looking at this in conjunction with the status indicators we discussed previously.

Hope to have a BETA release for you soon.

Toby
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Hi Brad,

We have just released LogViewPlus v2.5.42 as a beta release.  This version has a number of fixes for dropped connections, recovery and reporting - both in the transfer progress view and the main tree view:



Hope that helps.  Please let me know if you have any further issues or feedback.

Toby
Brad Konia
Brad Konia
Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)Junior Member (68 reputation)
Group: Forum Members
Posts: 48, Visits: 73
Unfortunately, the beta crashes immediately upon execution. I sent you the crash report.
LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Thanks for the crash report.  There is a problem loading one of the dependent libraries.  

Do you have any custom code running in LogViewPlus extending Clearcove.LogViewer.Common.dll?  If so, can you please update this library with the install file?
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search