Under which circumstances are the "Find next/previous bookmark" buttons greyed out?


Author
Message
danielf82
danielf82
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 9, Visits: 16
Hi all,

currently I have a merged log open that contains multiple bookmarks.
But the buttons for finding the next and previous ones are greyed out.
There is no helping text or popup that tells me why this is the case.
How do I find the reason?

Best Regards,
Daniel

LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Hi Daniel,

Thanks for reporting this issue.  I have just had a look and can confirm that this is a bug. 

We made significant changes to bookmarks in the latest release 2.5.37 and there appears to have been a gap in our testing.  The next / previous buttons work as expected when the source log file is selected, but not from merge files.  We will get this fixed for the next release. 

In the meantime, I would suggest navigating using the bookmark tool window in the lower left navigation area.   Also, if you add a bookmark directly to the merge file, navigation works as expected as long as that bookmark exists.  This a strange workaround, but it may be better than using navigation area.

Thanks again,

Toby
danielf82
danielf82
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 9, Visits: 16
Hi Toby,

thanks for the info.
Unfortunately your suggested workaround does not work for me.
There is no bookmark navigation in merged files, wether I added a bookmark there or not.
In the single log file, it seems to also find the ones I marked in the merge file correctly.

Best regards,
Daniel

LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Thanks for the update.  Is the bookmark tool window also not working?


danielf82
danielf82
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 9, Visits: 16
After I checked again it seems to work, the window is also showing.
But the entries are not really consistent with lines that are marked -1


LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
It looks like those "-1" bookmarks are invalid.  I suspect they do not exist and have not been cleaned up properly.  I am not able to recreate this issue locally. 

What happens if kcc.jsonl.log is refreshed?  How many bookmarks should be displayed?  Are you able to recreate the issue?
Edited 3 Months Ago by LogViewPlus Support
danielf82
danielf82
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 9, Visits: 16
All the lines with numbers seem valid.
Refreshing the kcc.jsonl.log does not fix it. Refreshing the merged file removes most of the entries, even valid ones.

This behaviour seems a bit erratic.
But I will wait for the next update to check how it behaves.

LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Are your log files being tailed?  If the log file is being updated, the bookmarks may become invalid on refresh.  

Unfortunately, I am unable to recreate these issues locally on version 2.5.37.  I will take a look for the next release and see if I can spot the issue.  At a minimum, I would expect invalid bookmarks to be removed from the view when the log file is refreshed.
danielf82
danielf82
New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)New Member (12 reputation)
Group: Forum Members
Posts: 9, Visits: 16
The files did not change while I had them open. They were copied over from a running system
I am using 2.5.32 here. I am now updating to 2.5.37 to see if its fixed

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search