custom parser not loading


Author
Message
Email User
Email User
New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)
Group: Forum Members
Posts: 21, Visits: 66

Hello,I've created a custom parser for my log files and it works perfect if I doeverything according to instruction. But seems like it's not possible to shareit (*.dll file) with other team members. They put this file to AppDatadirectory (folder with plugins) but LogViewPlus doesn't see it even in Pluginssection of settings. However this file appears in settings after the build fromVisual Studio. Is it possible to share this custom parser with other teammembers without deploying it on each local machine?


LogViewPlus Support
LogViewPlus Support
I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)
Group: Moderators
Posts: 188, Visits: 735
What dependencies does your parser have? There is a try catch around loading libraries. Maybe you're parser is throwing an exception which being swallowed by LogViewPlus?

I am not sure why your colleagues are not seeing the file. Once the file is installed into the plugins directory, it should be a simple matter of checking the "allow plugins" box and restarting. Are you running the same version of LogViewPlus as your colleagues?

If possible, can you please send me the code you use for your parser using our contact page? 
https://www.logviewplus.com/contact.aspx

Thanks,

Toby

Edited Last Year by Toby
Email User
Email User
New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)
Group: Forum Members
Posts: 21, Visits: 66

I'm sending you my solution and also you can find unit test project inside, so you don't need, I suppose, a sample log.  As I mentioned it works perfect if it's deployed on a local machine.

Thanks.


Edited Last Year by Email User
LogViewPlus Support
LogViewPlus Support
I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)
Group: Moderators
Posts: 188, Visits: 735
LogViewPlus is built with .Net 4.5 and your plugin is built using .Net 4.6. If your colleagues do not have .Net 4.6 or higher installed that might be causing the problem (LogViewPlus runs fine, but cannot load a 4.6 library). Can you please try rebuilding and deploying in .Net 4.5?

As I suspected, there is a try catch around loading plugins. There is error reporting built-in but, unfortunately, this appears to be broken. I have fixed this for the next release. I apologize for the confusion this is causing.

Aside from those issues, your plugin appears to be fine and is loading on my machine.

Thanks for reporting this issue. Please let me know if you continue to have problems after building in .Net 4.5.

Toby
LogViewPlus Support
LogViewPlus Support
I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)
Group: Moderators
Posts: 188, Visits: 735
Hi,

We have just released a very early beta of v2.2.9 which addresses the issue with error reporting. Running this version on a machine where you cannot load the parser may yield some insight. I am pretty certain that the issue is with loading your dll – some dependency is not being resolved.

You can download the beta from:
http://www.logviewplus.com/dist/logviewplus_setup_beta.zip

Thanks,

Toby
Email User
Email User
New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)
Group: Forum Members
Posts: 21, Visits: 66
Thank you, I will check it out and let you know if there still will be issues.
Edited Last Year by Email User
Email User
Email User
New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)New Member (37 reputation)
Group: Forum Members
Posts: 21, Visits: 66

It's working now - thanks.

I have two solutions for this and maybe it also will be useful for you to handle it somehow.  I'm attaching the screenshot with the first solution. The point is that after transferring the parser, Windows blocks it and therefore the file is closed
for usage. So once it's unblocked everything works fine even with newer versions of .Net framework (I tried 4.6.1 parser version with the current version of LogViewPlus).

Another solution - to use WinRAR archiver for packing the parser BUT (Important!) with an option "Save file streams" (screenshot is attached). Then once it's unpacked it works also fine. 




LogViewPlus Support
LogViewPlus Support
I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)I'm into this (233 reputation)
Group: Moderators
Posts: 188, Visits: 735
Glad to hear you got it working - thanks for letting me know!

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search