Date parser doesn't work correctly


Author
Message
xgjkrfyhjteocxbduf
xgjkrfyhjteocxbduf
New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)New Member (0 reputation)
Group: Forum Members
Posts: 1, Visits: 1
My log files stores the timestamp in a custom format, a sample value is "2021-05-22 14:43:06.4768".
If I try to use a parser, eg. "%d{yyyy-MM-dd HH:mm:ss.ffff}", the log grid shows the minute's value instead of the month's value in the date, eg. "2021-43-22".
The result is the same if I use "%d".


LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Apologies for the slow reply.  Our forum software incorrectly marked this post as spam (possibly because of the username) and I only just discovered it.

All log entries in LogViewPlus must have a valid date.   2021-43-22 is not a valid date, so I believe the date is being parsed correctly and this is just a display issue.  Can you please check your date display format in date & time settings and ensure you are using MM and not mm?

Hope that helps,

Toby
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search