How to get "Save Configuration" from popping up after saved?


Author
Message
KNERD
KNERD
New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)
Group: Forum Members
Posts: 2, Visits: 5
So, the "Save Configuration" pops up after you open a new type of log.

I see there is an option to open the Parser Wizard. Using that, I just went ahead and chose the option "The basic parser meets my needs" as a test, After saving, the not only does the "Save Configuration" pop right up again after clicking save, but continues to pop up after loading the same type of log again.

Looking in the settings, I see no means to stop this behavior. This is quite annoying.

How can that be stopped?

Thank you.

LogViewPlus Support
LogViewPlus Support
Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)
Group: Moderators
Posts: 1.1K, Visits: 3.6K
Thanks for reporting this issue.

Is the underlying log file being parsed successfully?  I was not able to reproduce the issue when the file could be parsed.  However, if the file cannot be parsed using the Basic Parser, the prompt does come up again.  This makes sense because there is a problem with the parser configuration which needs to be addressed. 

As a work-around, you could just cancel the dialog.

Hope that helps,

Toby
Edited 3 Months Ago by LogViewPlus Support
bespalex
bespalex
New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)
Group: Forum Members
Posts: 17, Visits: 31
I have got the same problem, one of the files I monitor cause pop-up of save parser each time on startup. It's been saved multiple times before, but each time it pops up again and asks what parser to use, and gives a correct suggestion from previously saved template. This doesn't happen with other files. What is the problem and how to save the parser template permanently?
LogViewPlus Support
LogViewPlus Support
Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)
Group: Moderators
Posts: 1.1K, Visits: 3.6K
Is the underlying file being parsed successfully?  This dialog is shown when parsing fails - regardless of whether or not an existing parser configuration was found.  It sounds like this behaviour may be causing some confusion.

Alternatively, this could also be a bug but I haven't yet been able to reproduce the issue locally.
bespalex
bespalex
New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)
Group: Forum Members
Posts: 17, Visits: 31
yes the file is parsed successfully, I just need to confirm the schema every time
bespalex
bespalex
New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)
Group: Forum Members
Posts: 17, Visits: 31
Here how it looks:

and the configuration is the same as it was before, so I basically need to press edit, save without changes.
bespalex
bespalex
New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)
Group: Forum Members
Posts: 17, Visits: 31
I also notice this happens when the file is empty to start with, contains only header row
LogViewPlus Support
LogViewPlus Support
Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)Respected User (1.8K reputation)
Group: Moderators
Posts: 1.1K, Visits: 3.6K
That error message is saying "there is data, but no log entries".  LogViewPlus thinks the file has not been parsed correctly and is giving you an opportunity to adjust the configuration.  If no adjustments are necessary, the dialog can be cancelled.
KNERD
KNERD
New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)New Member (6 reputation)
Group: Forum Members
Posts: 2, Visits: 5
Thanks for that.

After looking, I see some unusual tags were added to the log for some reason I don't know why, After removing all of them, it parsed the log file correctly using the basic parser.

bespalex
bespalex
New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)New Member (26 reputation)
Group: Forum Members
Posts: 17, Visits: 31
if I just cancel the dialog, it would not start loading without reloading first
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search