Having issue with DateTime parsing


Author
Message
Kevin Anstey
Kevin Anstey
New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)
Group: Forum Members
Posts: 2, Visits: 3
Hi,
I have starting using LogViewPlus recently and I am very pleased with it thus far.
However, I am having an issue with the parsing of time values from our logs.

I have created a parser mapping and was able to apply it to my log files (*.log) easily enough.
A sample line of our log file would typically look like the following (all on a single line)
2020-09-25 20:13:48,583550Z [1] INFO PackageManagementService Configuration: ConfigurationCache.MergeUpdatedPartsIntoPartsCache; Added part: DataAcquisitionMessaging to the cache

The parser mapping that I created seems to parse everything except that it only shows 3 digits of millisecond precision versus the 5 that our logger emits.  I have highlighted the timestamp portion of the sample log entry above.  All of our times are in UTC, hence the Z suffix on them.

I used a pattern parser in LogViewPlus and the parser arguments that I configured are as follows:
%d{yyyy-MM-dd HH:mm:ss,ffffffZ} %t %p %c %m%n

You can see that I included "5 letter fs" to indicate 5 digits of millisecond precision, which our machines are able to produce, in the parser configuration. 
However, when LogViewPlus produces the output in the UI, it displays only the first three digits of millisecond precision.
It is not rounding in any fashion based on the data, but rather is truncating the extra 2 digits.

Any help would be appreciated.


LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
Hi Kevin,

Thanks for taking the time to evaluate LogViewPlus.

It sounds like this is a display issue.  Have you tried modifying the time display format?
https://www.logviewplus.com/docs/date___time.html

Hope that helps,

Toby
Kevin Anstey
Kevin Anstey
New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)
Group: Forum Members
Posts: 2, Visits: 3
I had just found that setting as your reply came in Smile
Thanks.

Appreciate the quick response.


LogViewPlus Support
LogViewPlus Support
Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)Forum Expert (925 reputation)
Group: Moderators
Posts: 656, Visits: 2K
:-)  Glad that helped.  Please let me know if you have any further questions or issues.

Toby
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Similar Topics

Login

Explore
Messages
Mentions
Search